読者です 読者をやめる 読者になる 読者になる

echo v:version

ある環境ではインストールされているvimを自由に変更できない。*1

:echo v:version
700

700だとFuzzyFinderさんが使えない・・・
痛いよなぁ。


Linuxの各ディストリのstableのvimのバージョンはどのバージョンが多いんだろ?
確かetchもstableだとまだ7.0だったかな?
自分はdebianではtestのvim7.1使っている。

:h v:version

ヘルプ見た。
5.0なら500
5.1なら501

もし、5.10なら510という感じかな。
パッチが適用されているかもhas関数で調べられるんですね。

:echo has('guyon')
0

そんなパッチなんてない。

*1:単なるインストールしているソフトを変更しないでねという制約